Help

Questions and Feature Requests

All Topics

Software Download

March 29, 2017
Do you have any older versions of this software? I like the program and want to use it, but my laptop at church does not meet the requirements of Mac OS X 10.9 or higher. Currently I have OS X 10.6.8
I can not upgrade my software, because my computer is older and will not be able to handle the new software. So I was wondering if you have an older version of Worship Extreme that I could download and use. Any help would be very appreciated. 

Thanks 
Posted by Tim
March 29, 2017
Hi Tim-

Thanks for the post.  Unfortunately, we don't have an old build for Mac OS 10.6.  Is you mac able to upgrade to a newer version of MacOS?
Posted by Adam
March 29, 2017
Unfortunately no. If I do the laptop would slow down too much. 

Thanks for the quick response. 
Posted by Tim
January 3, 2019
yeah, it would be nice to have ALL the system requirements on the website. like, gee i dunno, minimum OS requirements, RAM needed. stuff like that.
Posted by Morgan

Login to post a reply

1