arrow_back Return

WE freezes while editing

June 11, 2019
Is anyone else experiencing several seconds of "freeze" when editing cues? Every time I make any sort of change to a cue, or move a cue to another place in the cue list, Worship Extreme freezes up for 5-6 seconds. If I start with last Sunday's cue lists and make changes to several cues for two different services, all those freezes add up. I run WE on two identical computers at the church, plus a third computer at home for occasional edits and last minute changes on Saturday. The church computers, are 8th gen i7 machines with 16 GB of RAM, which should be plenty fast enough to run the software smoothly. The home computer is a 4th gen i3 with 8 GB of RAM. All three machines exhibit this delay while editing cues. I'm wondering if it has something to do with auto saving to the cloud. I would love to know if this is a known issue and if there is a fix for it.
Posted by Chuck
July 5, 2019
Same thing happens for me. I actually just sent in a support request regarding this. I'm hoping it's just some setting on the computer itself that can be updated to get rid of this. Not being able to edit things on fly while presenting is a huge detractor for an otherwise great program.
Posted by DCP Media
July 5, 2019
I put in a support request and it didn’t seem to be a known issue with an easy fix. Here’s my own fix, which is more of a workaround. I had been creating new cue lists from previous cue lists. I think they were getting kind of glitchy from deleting, adding and editing cues over and over. So, I started all over from an empty cue list, and everything is working much better. Now I can use that cue list as a template each week and my cue lists will stay pretty clean. I hope I explained that ok.
Posted by Chuck
July 5, 2019
My issue might be different than yours then. It doesn't matter if I have a new cue list or not. Support was able to duplicate my issue and said they'd work on putting out a fix in a future update.
Posted by Jesse
July 5, 2019
FYI I'm the same as DCP Media above. Just a different account.
Posted by Jesse
July 16, 2019
Hi all- We have found the root cause of this and have a fix out in version 4.42. Currently this is an early adopter release and you can download it at https://www.worshipextreme.com/docs/85-early-adopter-releases. Looking forward to your feedback. Thanks!
Posted by Adam
Login to post a reply
1